Softphone, webphone and VoIP server Forum

HomeHomeDiscussionsDiscussionsMizu WebphoneMizu Webphonebad 127.0.0.0 ip in the Via fieldbad 127.0.0.0 ip in the Via field
Previous
 
Next
New Post
6/16/2010 3:53 PM
 

Hi, I'm testing the trial version of the webphone on a linux, which has three interfaces: lo0, eth0 and eth1. Of course, lo0 is the local 127.0.0.0 interface. When I try to register the webphone on an asterisk located on a network reached through the eth0 interface, the operation fails because the webphone is sending 127.0.0.0 in the Via field instead sending the eth0 one and the response from the asterisk is lost, as I was able to see with wireshark. However, if I try the register operation from a zoiper softphone running on the same linux machine like the webphone, the register operation success and the Via field carries the eth0 IP, not the lo0 one. Therefore, my questions are as follow: is it a bug? does anyone know if there is any way to instruct webphone what interface IP to use for the Via field?

Thanks in advanced.

 

 
New Post
6/18/2010 12:18 PM
 

Hello

The webphone just pick up the first interface. We might change this and adjust after the serveraddress parameter in the next version, but a better solution would be if you turn off the via ip checking on your server side. This should be done on all servers who are interacting with customers. In this way, the server would just respond to the address from where it is receiving the request. The via header could be useful only for some b2b scenarios.

In don't remember exactly how you can turn off the via ip checking, but you should be able to find it easily on the asterisk forums.

 

 

 

 

 
New Post
6/18/2010 12:19 PM
 
 
New Post
6/21/2010 11:51 AM
 

We had to set "Nat=yes" (it was "never" before) on sip.conf in the asterisk for it started to work, but we don't understand why because both of them, the Webphone and the asterisk, were in the same network without a router between them and other softphones didn't need Nat=yes to work either. We'll continue investigating the issue.

Thanks

 

 
New Post
6/27/2010 12:28 AM
 

Hello

The reason is that the webphone might insert 127.0.0.1 in the via in some circumstances. We already fixed it in the upcoming release.

But the VoIP server should always consider the source address also and not only the address sent in the signaling because that is often wrong (especially when the devices are behind NAT ...which is not your case here)

 
New Post
11/21/2012 12:45 AM
 
Is this not a default address and could work on any connection?

Smile is for the way you look at me!
 
Previous
 
Next
HomeHomeDiscussionsDiscussionsMizu WebphoneMizu Webphonebad 127.0.0.0 ip in the Via fieldbad 127.0.0.0 ip in the Via field


You need to register / login to be able to post in the forum